FAQ

Java APIの対応JDK/JREバージョンは?

公開日:2007/08/09

  • V11
  • V10
  • V9
  • V8
  • V7
  • V6
  • V5

Question

Create!FormランタイムのJava API(CreateFormLib.jar、java2create.jar)は、どのバージョンのJDK/JREに対応していますか。


Answer

ランタイムのバージョンによって、対応しているJDK/JREは異なります。

■V11
Java API(CreateFormLib.jar)は、以下のJava(JDK/JRE)に対応しています。

Oracle Java SE 7、8、9、10、11 (HotSpot)
OpenJDK 10、11

■V10
Java API(CreateFormLib.jar)は、以下のJava(JDK/JRE)に対応しています。

 ●V10.03以前
 Oracle Java SE 5、6、7 (HotSpot)

 ●V10.04、V10.05
 Oracle Java SE 5、6、7、8 (HotSpot)

 ●V10.08
 Oracle Java SE 5、6、7、8、10、11 (HotSpot)
 OpenJDK 10、11

■V9
Java API(CreateFormLib.jar)は、以下のJava(JDK/JRE)に対応しています。

 ●V9.19以前
 Oracle Java SE 1.4、5、6、7 (HotSpot)

 ●V9.20
 Oracle Java SE 1.4、5、6、7、11 (HotSpot)
 OpenJDK 11

■V8以前(V5、V6、V7、V8)
Java API(CreateFormLib.jar、java2create.jar)は、以下のJava(JDK/JRE)に対応しています。

 Oracle Java SE 1.4、5、6、7 (HotSpot)

この質問・回答は役に立ちましたか?

このページのよい点、悪い点を教えてください!FAQ改善の参考とさせていただきます。

  • 個人情報は入力されないようご注意ください。
    弊社からの回答をご希望の場合は、画面上部のメニューより「お問い合わせ」をご利用ください。
  • 最後に「送信」を押すことでコメントが送信されます。

検索